Skip to content

registry.hub.docker.com/zegl/kube-score (alpine 3.17.0)

Trivy Image Scan

  • Image: registry.hub.docker.com/zegl/kube-score (alpine 3.17.0)
  • Scan date: 2024-07-25

registry.hub.docker.com/zegl/kube-score (alpine 3.17.0) (alpine)

Package Vulnerability ID Severity Installed Version Fixed Version Links
busybox CVE-2023-42363 MEDIUM 1.35.0-r29 1.35.0-r31
busybox CVE-2023-42364 MEDIUM 1.35.0-r29 1.35.0-r31
busybox CVE-2023-42365 MEDIUM 1.35.0-r29 1.35.0-r31
busybox CVE-2023-42366 MEDIUM 1.35.0-r29 1.35.0-r30
busybox-binsh CVE-2023-42363 MEDIUM 1.35.0-r29 1.35.0-r31
busybox-binsh CVE-2023-42364 MEDIUM 1.35.0-r29 1.35.0-r31
busybox-binsh CVE-2023-42365 MEDIUM 1.35.0-r29 1.35.0-r31
busybox-binsh CVE-2023-42366 MEDIUM 1.35.0-r29 1.35.0-r30
libcrypto3 CVE-2023-5363 HIGH 3.0.9-r1 3.0.12-r0
libcrypto3 CVE-2023-2975 MEDIUM 3.0.9-r1 3.0.9-r2
libcrypto3 CVE-2023-3446 MEDIUM 3.0.9-r1 3.0.9-r3
libcrypto3 CVE-2023-3817 MEDIUM 3.0.9-r1 3.0.10-r0
libcrypto3 CVE-2023-5678 MEDIUM 3.0.9-r1 3.0.12-r1
libcrypto3 CVE-2023-6129 MEDIUM 3.0.9-r1 3.0.12-r2
libcrypto3 CVE-2023-6237 MEDIUM 3.0.9-r1 3.0.12-r3
libcrypto3 CVE-2024-0727 MEDIUM 3.0.9-r1 3.0.12-r4
libcrypto3 CVE-2024-4603 MEDIUM 3.0.9-r1 3.0.13-r0
libcrypto3 CVE-2024-4741 MEDIUM 3.0.9-r1 3.0.14-r0
libcrypto3 CVE-2024-5535 MEDIUM 3.0.9-r1 3.0.14-r0
libcrypto3 CVE-2024-2511 LOW 3.0.9-r1 3.0.12-r5
libcurl CVE-2023-38545 CRITICAL 8.1.2-r0 8.4.0-r0
libcurl CVE-2023-38039 HIGH 8.1.2-r0 8.3.0-r0
libcurl CVE-2023-46218 MEDIUM 8.1.2-r0 8.5.0-r0
libcurl CVE-2023-46219 MEDIUM 8.1.2-r0 8.5.0-r0
libcurl CVE-2023-38546 LOW 8.1.2-r0 8.4.0-r0
libexpat CVE-2023-52425 HIGH 2.5.0-r0 2.6.0-r0
libexpat CVE-2024-28757 HIGH 2.5.0-r0 2.6.2-r0
libexpat CVE-2023-52426 MEDIUM 2.5.0-r0 2.6.0-r0
libssl3 CVE-2023-5363 HIGH 3.0.9-r1 3.0.12-r0
libssl3 CVE-2023-2975 MEDIUM 3.0.9-r1 3.0.9-r2
libssl3 CVE-2023-3446 MEDIUM 3.0.9-r1 3.0.9-r3
libssl3 CVE-2023-3817 MEDIUM 3.0.9-r1 3.0.10-r0
libssl3 CVE-2023-5678 MEDIUM 3.0.9-r1 3.0.12-r1
libssl3 CVE-2023-6129 MEDIUM 3.0.9-r1 3.0.12-r2
libssl3 CVE-2023-6237 MEDIUM 3.0.9-r1 3.0.12-r3
libssl3 CVE-2024-0727 MEDIUM 3.0.9-r1 3.0.12-r4
libssl3 CVE-2024-4603 MEDIUM 3.0.9-r1 3.0.13-r0
libssl3 CVE-2024-4741 MEDIUM 3.0.9-r1 3.0.14-r0
libssl3 CVE-2024-5535 MEDIUM 3.0.9-r1 3.0.14-r0
libssl3 CVE-2024-2511 LOW 3.0.9-r1 3.0.12-r5
nghttp2-libs CVE-2023-35945 HIGH 1.51.0-r0 1.51.0-r1
nghttp2-libs CVE-2023-44487 HIGH 1.51.0-r0 1.51.0-r2
ssl_client CVE-2023-42363 MEDIUM 1.35.0-r29 1.35.0-r31
ssl_client CVE-2023-42364 MEDIUM 1.35.0-r29 1.35.0-r31
ssl_client CVE-2023-42365 MEDIUM 1.35.0-r29 1.35.0-r31
ssl_client CVE-2023-42366 MEDIUM 1.35.0-r29 1.35.0-r30
No Misconfigurations found

usr/bin/helm (gobinary)

Package Vulnerability ID Severity Installed Version Fixed Version Links
github.com/containerd/containerd CVE-2022-23471 MEDIUM v1.6.6 1.5.16, 1.6.12
github.com/containerd/containerd CVE-2023-25153 MEDIUM v1.6.6 1.5.18, 1.6.18
github.com/containerd/containerd CVE-2023-25173 MEDIUM v1.6.6 1.5.18, 1.6.18
github.com/containerd/containerd GHSA-7ww5-4wqc-m92c MEDIUM v1.6.6 1.6.26, 1.7.11
github.com/cyphar/filepath-securejoin GHSA-6xv5-86q9-7xr8 MEDIUM v0.2.3 0.2.4
github.com/docker/distribution CVE-2023-2253 HIGH v2.8.1+incompatible 2.8.2-beta.1
github.com/docker/docker CVE-2023-28840 HIGH v20.10.17+incompatible 20.10.24, 23.0.3
github.com/docker/docker CVE-2022-36109 MEDIUM v20.10.17+incompatible 20.10.18
github.com/docker/docker CVE-2023-28841 MEDIUM v20.10.17+incompatible 20.10.24, 23.0.3
github.com/docker/docker CVE-2023-28842 MEDIUM v20.10.17+incompatible 20.10.24, 23.0.3
github.com/docker/docker CVE-2024-24557 MEDIUM v20.10.17+incompatible 24.0.9, 25.0.2
github.com/docker/docker CVE-2024-29018 MEDIUM v20.10.17+incompatible 26.0.0-rc3, 25.0.5, 23.0.11
github.com/docker/docker GHSA-jq35-85cj-fj4p MEDIUM v20.10.17+incompatible 24.0.7, 23.0.8, 20.10.27
github.com/docker/docker GHSA-vp35-85q5-9f25 LOW v20.10.17+incompatible 20.10.20
golang.org/x/crypto CVE-2023-48795 MEDIUM v0.0.0-20220525230936-793ad666bf5e 0.17.0
golang.org/x/net CVE-2022-27664 HIGH v0.0.0-20220722155237-a158d28d115b 0.0.0-20220906165146-f3363e06e74c
golang.org/x/net CVE-2022-41721 HIGH v0.0.0-20220722155237-a158d28d115b 0.1.1-0.20221104162952-702349b0e862
golang.org/x/net CVE-2022-41723 HIGH v0.0.0-20220722155237-a158d28d115b 0.7.0
golang.org/x/net CVE-2023-39325 HIGH v0.0.0-20220722155237-a158d28d115b 0.17.0
golang.org/x/net CVE-2022-41717 MEDIUM v0.0.0-20220722155237-a158d28d115b 0.4.0
golang.org/x/net CVE-2023-3978 MEDIUM v0.0.0-20220722155237-a158d28d115b 0.13.0
golang.org/x/net CVE-2023-44487 MEDIUM v0.0.0-20220722155237-a158d28d115b 0.17.0
golang.org/x/net CVE-2023-45288 MEDIUM v0.0.0-20220722155237-a158d28d115b 0.23.0
golang.org/x/text CVE-2022-32149 HIGH v0.3.7 0.3.8
google.golang.org/grpc GHSA-m425-mq94-257g HIGH v1.47.0 1.56.3, 1.57.1, 1.58.3
google.golang.org/grpc CVE-2023-44487 MEDIUM v1.47.0 1.58.3, 1.57.1, 1.56.3
google.golang.org/protobuf CVE-2024-24786 MEDIUM v1.28.0 1.33.0
stdlib CVE-2023-24538 CRITICAL 1.18.8 1.19.8, 1.20.3
stdlib CVE-2023-24540 CRITICAL 1.18.8 1.19.9, 1.20.4
stdlib CVE-2024-24790 CRITICAL 1.18.8 1.21.11, 1.22.4
stdlib CVE-2022-41720 HIGH 1.18.8 1.18.9, 1.19.4
stdlib CVE-2022-41722 HIGH 1.18.8 1.19.6, 1.20.1
stdlib CVE-2022-41723 HIGH 1.18.8 1.19.6, 1.20.1
stdlib CVE-2022-41724 HIGH 1.18.8 1.19.6, 1.20.1
stdlib CVE-2022-41725 HIGH 1.18.8 1.19.6, 1.20.1
stdlib CVE-2023-24534 HIGH 1.18.8 1.19.8, 1.20.3
stdlib CVE-2023-24536 HIGH 1.18.8 1.19.8, 1.20.3
stdlib CVE-2023-24537 HIGH 1.18.8 1.19.8, 1.20.3
stdlib CVE-2023-24539 HIGH 1.18.8 1.19.9, 1.20.4
stdlib CVE-2023-29400 HIGH 1.18.8 1.19.9, 1.20.4
stdlib CVE-2023-29403 HIGH 1.18.8 1.19.10, 1.20.5
stdlib CVE-2023-39325 HIGH 1.18.8 1.20.10, 1.21.3
stdlib CVE-2023-45283 HIGH 1.18.8 1.20.11, 1.21.4, 1.20.12, 1.21.5
stdlib CVE-2023-45287 HIGH 1.18.8 1.20.0
stdlib CVE-2023-45288 HIGH 1.18.8 1.21.9, 1.22.2
stdlib CVE-2022-41717 MEDIUM 1.18.8 1.18.9, 1.19.4
stdlib CVE-2023-24532 MEDIUM 1.18.8 1.19.7, 1.20.2
stdlib CVE-2023-29406 MEDIUM 1.18.8 1.19.11, 1.20.6
stdlib CVE-2023-29409 MEDIUM 1.18.8 1.19.12, 1.20.7, 1.21.0-rc.4
stdlib CVE-2023-39318 MEDIUM 1.18.8 1.20.8, 1.21.1
10 other vulnerabilities found...
No Misconfigurations found

usr/bin/kube-score (gobinary)

Package Vulnerability ID Severity Installed Version Fixed Version Links
golang.org/x/net CVE-2023-45288 MEDIUM v0.19.0 0.23.0
stdlib CVE-2024-24790 CRITICAL 1.21.6 1.21.11, 1.22.4
stdlib CVE-2023-45288 HIGH 1.21.6 1.21.9, 1.22.2
stdlib CVE-2023-45289 MEDIUM 1.21.6 1.21.8, 1.22.1
stdlib CVE-2023-45290 MEDIUM 1.21.6 1.21.8, 1.22.1
stdlib CVE-2024-24783 MEDIUM 1.21.6 1.21.8, 1.22.1
stdlib CVE-2024-24784 MEDIUM 1.21.6 1.21.8, 1.22.1
stdlib CVE-2024-24785 MEDIUM 1.21.6 1.21.8, 1.22.1
stdlib CVE-2024-24789 MEDIUM 1.21.6 1.21.11, 1.22.4
stdlib CVE-2024-24791 MEDIUM 1.21.6 1.21.12, 1.22.5
No Misconfigurations found

usr/bin/kustomize (gobinary)

Package Vulnerability ID Severity Installed Version Fixed Version Links
golang.org/x/net CVE-2022-27664 HIGH v0.0.0-20220127200216-cd36cc0744dd 0.0.0-20220906165146-f3363e06e74c
golang.org/x/net CVE-2022-41723 HIGH v0.0.0-20220127200216-cd36cc0744dd 0.7.0
golang.org/x/net CVE-2023-39325 HIGH v0.0.0-20220127200216-cd36cc0744dd 0.17.0
golang.org/x/net CVE-2022-41717 MEDIUM v0.0.0-20220127200216-cd36cc0744dd 0.4.0
golang.org/x/net CVE-2023-3978 MEDIUM v0.0.0-20220127200216-cd36cc0744dd 0.13.0
golang.org/x/net CVE-2023-44487 MEDIUM v0.0.0-20220127200216-cd36cc0744dd 0.17.0
golang.org/x/net CVE-2023-45288 MEDIUM v0.0.0-20220127200216-cd36cc0744dd 0.23.0
golang.org/x/text CVE-2022-32149 HIGH v0.3.7 0.3.8
google.golang.org/protobuf CVE-2024-24786 MEDIUM v1.28.0 1.33.0
gopkg.in/yaml.v3 CVE-2022-28948 HIGH v3.0.0-20210107192922-496545a6307b 3.0.0-20220521103104-8f96da9f5d5e
stdlib CVE-2023-24538 CRITICAL 1.18.5 1.19.8, 1.20.3
stdlib CVE-2023-24540 CRITICAL 1.18.5 1.19.9, 1.20.4
stdlib CVE-2024-24790 CRITICAL 1.18.5 1.21.11, 1.22.4
stdlib CVE-2022-27664 HIGH 1.18.5 1.18.6, 1.19.1
stdlib CVE-2022-2879 HIGH 1.18.5 1.18.7, 1.19.2
stdlib CVE-2022-2880 HIGH 1.18.5 1.18.7, 1.19.2
stdlib CVE-2022-41715 HIGH 1.18.5 1.18.7, 1.19.2
stdlib CVE-2022-41716 HIGH 1.18.5 1.18.8, 1.19.3
stdlib CVE-2022-41720 HIGH 1.18.5 1.18.9, 1.19.4
stdlib CVE-2022-41722 HIGH 1.18.5 1.19.6, 1.20.1
stdlib CVE-2022-41723 HIGH 1.18.5 1.19.6, 1.20.1
stdlib CVE-2022-41724 HIGH 1.18.5 1.19.6, 1.20.1
stdlib CVE-2022-41725 HIGH 1.18.5 1.19.6, 1.20.1
stdlib CVE-2023-24534 HIGH 1.18.5 1.19.8, 1.20.3
stdlib CVE-2023-24536 HIGH 1.18.5 1.19.8, 1.20.3
stdlib CVE-2023-24537 HIGH 1.18.5 1.19.8, 1.20.3
stdlib CVE-2023-24539 HIGH 1.18.5 1.19.9, 1.20.4
stdlib CVE-2023-29400 HIGH 1.18.5 1.19.9, 1.20.4
stdlib CVE-2023-29403 HIGH 1.18.5 1.19.10, 1.20.5
stdlib CVE-2023-39325 HIGH 1.18.5 1.20.10, 1.21.3
stdlib CVE-2023-45283 HIGH 1.18.5 1.20.11, 1.21.4, 1.20.12, 1.21.5
stdlib CVE-2023-45287 HIGH 1.18.5 1.20.0
stdlib CVE-2023-45288 HIGH 1.18.5 1.21.9, 1.22.2
stdlib CVE-2022-41717 MEDIUM 1.18.5 1.18.9, 1.19.4
stdlib CVE-2023-24532 MEDIUM 1.18.5 1.19.7, 1.20.2
stdlib CVE-2023-29406 MEDIUM 1.18.5 1.19.11, 1.20.6
stdlib CVE-2023-29409 MEDIUM 1.18.5 1.19.12, 1.20.7, 1.21.0-rc.4
stdlib CVE-2023-39318 MEDIUM 1.18.5 1.20.8, 1.21.1
stdlib CVE-2023-39319 MEDIUM 1.18.5 1.20.8, 1.21.1
stdlib CVE-2023-39326 MEDIUM 1.18.5 1.20.12, 1.21.5
stdlib CVE-2023-45284 MEDIUM 1.18.5 1.20.11, 1.21.4
stdlib CVE-2023-45289 MEDIUM 1.18.5 1.21.8, 1.22.1
stdlib CVE-2023-45290 MEDIUM 1.18.5 1.21.8, 1.22.1
stdlib CVE-2024-24783 MEDIUM 1.18.5 1.21.8, 1.22.1
stdlib CVE-2024-24784 MEDIUM 1.18.5 1.21.8, 1.22.1
stdlib CVE-2024-24785 MEDIUM 1.18.5 1.21.8, 1.22.1
stdlib CVE-2024-24789 MEDIUM 1.18.5 1.21.11, 1.22.4
stdlib CVE-2024-24791 MEDIUM 1.18.5 1.21.12, 1.22.5
No Misconfigurations found