Skip to content

quay.io/openshift/origin-cli:latest (redhat 8.6)

Trivy Image Scan

  • Image: quay.io/openshift/origin-cli:latest (redhat 8.6)
  • Scan date: 2024-07-25

quay.io/openshift/origin-cli:latest (redhat 8.6) (redhat)

Package Vulnerability ID Severity Installed Version Fixed Version Links
bind-libs CVE-2023-4408 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs CVE-2023-50387 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs CVE-2023-50868 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs CVE-2021-25220 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs CVE-2022-2795 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs CVE-2022-3094 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs-lite CVE-2023-4408 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs-lite CVE-2023-50387 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs-lite CVE-2023-50868 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs-lite CVE-2021-25220 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs-lite CVE-2022-2795 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-libs-lite CVE-2022-3094 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-license CVE-2023-4408 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-license CVE-2023-50387 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-license CVE-2023-50868 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-license CVE-2021-25220 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-license CVE-2022-2795 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-license CVE-2022-3094 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-utils CVE-2023-4408 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-utils CVE-2023-50387 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-utils CVE-2023-50868 HIGH 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-utils CVE-2021-25220 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-utils CVE-2022-2795 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
bind-utils CVE-2022-3094 MEDIUM 32:9.11.36-3.el8_6.5 32:9.11.36-3.el8_6.7
expat CVE-2023-52425 MEDIUM 2.2.5-8.el8_6.4 2.2.5-8.el8_6.5
glibc CVE-2024-2961 HIGH 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc CVE-2024-33599 HIGH 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc CVE-2024-33600 MEDIUM 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc CVE-2024-33601 LOW 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc CVE-2024-33602 LOW 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-common CVE-2024-2961 HIGH 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-common CVE-2024-33599 HIGH 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-common CVE-2024-33600 MEDIUM 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-common CVE-2024-33601 LOW 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-common CVE-2024-33602 LOW 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-gconv-extra CVE-2024-2961 HIGH 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-gconv-extra CVE-2024-33599 HIGH 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-gconv-extra CVE-2024-33600 MEDIUM 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-gconv-extra CVE-2024-33601 LOW 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-gconv-extra CVE-2024-33602 LOW 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-langpack-en CVE-2024-2961 HIGH 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-langpack-en CVE-2024-33599 HIGH 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-langpack-en CVE-2024-33600 MEDIUM 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-langpack-en CVE-2024-33601 LOW 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-langpack-en CVE-2024-33602 LOW 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-minimal-langpack CVE-2024-2961 HIGH 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-minimal-langpack CVE-2024-33599 HIGH 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-minimal-langpack CVE-2024-33600 MEDIUM 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-minimal-langpack CVE-2024-33601 LOW 2.28-189.8.el8_6 2.28-189.10.el8_6
glibc-minimal-langpack CVE-2024-33602 LOW 2.28-189.8.el8_6 2.28-189.10.el8_6
9 other vulnerabilities found...
No Misconfigurations found

usr/bin/oc (gobinary)

Package Vulnerability ID Severity Installed Version Fixed Version Links
github.com/containerd/containerd GHSA-7ww5-4wqc-m92c MEDIUM v1.7.0 1.6.26, 1.7.11
github.com/containers/image/v5 CVE-2024-3727 HIGH v5.29.0 5.30.1, 5.29.3
github.com/docker/docker CVE-2024-24557 MEDIUM v24.0.7+incompatible 24.0.9, 25.0.2
github.com/go-jose/go-jose/v3 CVE-2024-28180 MEDIUM v3.0.1 3.0.3
github.com/moby/buildkit CVE-2024-23652 CRITICAL v0.0.0-20181107081847-c3a857e3fca0 0.12.5
github.com/moby/buildkit CVE-2024-23653 CRITICAL v0.0.0-20181107081847-c3a857e3fca0 0.12.5
github.com/moby/buildkit CVE-2024-23651 HIGH v0.0.0-20181107081847-c3a857e3fca0 0.12.5
github.com/moby/buildkit CVE-2024-23650 MEDIUM v0.0.0-20181107081847-c3a857e3fca0 0.12.5
github.com/opencontainers/runc CVE-2024-21626 HIGH v1.1.10 1.1.12
golang.org/x/net CVE-2023-45288 MEDIUM v0.20.0 0.23.0
google.golang.org/protobuf CVE-2024-24786 MEDIUM v1.31.0 1.33.0
gopkg.in/go-jose/go-jose.v2 CVE-2024-28180 MEDIUM v2.6.1 2.6.3
stdlib CVE-2024-24790 CRITICAL 1.21.7 1.21.11, 1.22.4
stdlib CVE-2023-45288 HIGH 1.21.7 1.21.9, 1.22.2
stdlib CVE-2023-45289 MEDIUM 1.21.7 1.21.8, 1.22.1
stdlib CVE-2023-45290 MEDIUM 1.21.7 1.21.8, 1.22.1
stdlib CVE-2024-24783 MEDIUM 1.21.7 1.21.8, 1.22.1
stdlib CVE-2024-24784 MEDIUM 1.21.7 1.21.8, 1.22.1
stdlib CVE-2024-24785 MEDIUM 1.21.7 1.21.8, 1.22.1
stdlib CVE-2024-24789 MEDIUM 1.21.7 1.21.11, 1.22.4
stdlib CVE-2024-24791 MEDIUM 1.21.7 1.21.12, 1.22.5
No Misconfigurations found